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‘Explor er’ Style Trees in SavView

1 2 3

SavView presents a considerable amount of information both as
model input and model output.  The wealth of information is
organized hierarchically, to help users understand how the
information relates, and to avoid overwhelming users.

The tool used to relate information is an explorer style tree, named for
the Windows Explorer program used by most Windows users to
look at and manipulate files.

When an explorer tree is first viewed, such as the map tree shown
below, only the top level of the hierarchy is visible (1).

When the user double-click upon the topic of interest, perhaps
“Animals”, the tree expands to show the detail underneath.  In this
case, the tree shows the main animal groups.
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Exercise:  Experiment with the parameter and map trees in SavView.

Method:  Use the methods listed on page 17 to open a set of param-
eters in SavView.  Double-click upon the various entries.  You’ll no-
tice that the parameter tree is very simple.  Now go under the menu
entry “View” and select “Maps”, and experiment further with that
tree.  You’ll find it is more complex, with some sections having three
levels.

For most of the animal groups, the tree stops (the ending ‘leaves’ have
been reached).  For five of the groups, however, the population is
divided further, represented by the boxed ‘+’.  Clicking upon the
‘+’  will expand that part of the tree further, and in the example, we
learn that there are both migratory and resident populations of
wildebeest in NCA-Savanna.  When expanded, the ‘+’ changes to a
‘-’, and the tree may be collapsed to hide that portion.  Similarly, to
hide any portion of the tree, double-click upon the name.
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Visual clues are given for users to know just what may be selected in
SavView, and what is currently mapped.

Each item in the SavView trees has a small box to the left of the
name.  In some cases, these boxes are gray, and clicking upon them
will have no effect (except to expand or collapse the tree if double-
clicked).  Some of the tree entries have black boxes.  Clicking
upon those boxes will change the information shown in the large
window on the right.

In addition, a large blue check will be placed in the selected item,
such as in (2) above.  To keep the user informed of selected items,
even if the tree is collapsed, a gray check is placed at all the levels
above the currently selected item.  When viewing parameters or
maps, only one kind of information may be viewed at one time
(although not strictly true for maps; more later).  Because of that,

Making Selections in Trees in SavView

1 2 3
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Exercise:  Experiment with the parameter and map trees in SavView,
using the methods on the previous page.

Notes:  The tree in (3) is a blend of the map and chart trees in
SavView, used only for illustration.  It does not appear in SavView.

selecting one item to turn-on will turn-off any other items selected.
That is not the case when viewing charts, because more than one
line may be placed upon a chart.  In that tree, some boxes [such as
Grazing antelope in (3)] have a black box, even though there are
more entries below that item (that is, “migratory” and “resident”).
That black box is present as a shortcut.  If you wished to plot both
types of information, clicking upon the black box above would do
so, and mark both entries with blue checks and the box selected
with a gray check.

Clicking any entry that has a black box and check in it will turn-off
that item, if working with charts.  In the parameter and mapping
sections, clicking upon a selected item has no effect.
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Like most programs, the menus in SavView offer more choices than
are available on the button bar.  The main menu entries are typical
as well: File, Edit, View, Run, and Help.  The details of the entries
are shown on the following pages.

Menu Items in SavView - File

Save saves the changes made to parameters, replacing the file opened.
If changes have not been made, Save is grayed-out.  CTRL-S is a
shortcut for Save.

Save as opens a window that allows the user to select a new file used
to store the current parameters.  Pressing F12 is a shortcut.

Revert restores the current parameter set to the values stored within
the parameter file.  If changes are made and then the user wishes to
discard them, they may use Revert.  This button is not available
until parameters are changed.

Export results opens a window that allows the user to save Savanna
output to text files easily imported into spreadsheet programs, and

The File menu contains entries to open and
save files, output results, and exit
SavView.

New reads parameters from a default file,
which must be saved under a new name.
In general, New is not used, because
existing files are opened, modified, and
saved under the same or a new name.
CTRL-N is a shortcut for New.

Open shows a dialog window allowing the
user to select a file from which to read
parameters.  CTRL-O is a shortcut for
Open.
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text files in a common format used by geographic information
systems, to store maps.

Print setup opens a dialog window commonly found in Windows
programs, which allows the user to format the printer output on the
page and select printers.

Print opens a dialog window that will send the currently selected
Savanna output to the printer.  CTRL-P is the shortcut to print.

Options opens an options window that allows the user to control how
SavView behaves.

Exit stops SavView and unloads all its components.  If  Savanna is
running when SavView is stopped, Savanna will continue
uninterrupted..
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Menu Items in SavView - Edit, View

Charts displays the section of SavView that allows the user to view
changes over time in the ecosystem modeled.  Up to four charts
may be displayed.  After entering the Edit menu, ALT-H is a
shortcut for Charts.  When first displayed, a blank chart (or charts)
is represented by dashes centered on the chart area.

Map displays the mapping portion of SavView, with up to 12
individual maps displayed.  After entering the Edit menu, ALT-M is
a shortcut for Maps.  As for charts, when first displayed, a blank
map (or maps) is represented by dashes centered on the map area.

The Edit menu allows a user to edit or view
parameters, charts, or maps.  ALT-E is a
shortcut for Edit.

Parameters displays the tree and window that
allows the user to change parameter values in
preparation for running Savanna.  After
entering the Edit menu, ALT-E is a shortcut
for Parameters.  The first time the parameters
window is selected, the animal population file
is selected.

The View menu changes the items displayed by
SavView.

Detail will open a submenu allowing users to
change the level of detail shown in
SavView.

Parameters displays the parameter window,
and has the same effect as selecting
Parameters under Edit.

Charts displays the chart window, and has the
same effect as selecting Chart under Edit.
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Maps displays the mapping windows of SavView, and has the same
effect as selecting Maps under Edit.

View opens a submenu that allows several changes to be made to how
SavView display charts and maps.

Refresh will redraw the screen if it should become corrupted.
Sometimes portions of other programs or other errors will erase
portions of the display, for example.  Refresh will restore the
display.

The submenu under the Detail includes
options to display a low level of
detail in Savview, a moderate level
of detail, or the default, a high level
of detail.  Reducing the detail level,
for example, would remove entries in
the parameters, charting, and
mapping trees, simplifying the
program’s appearance.
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Menu Items in SavView - View in View

Full screen serves as a shortcut, turning both the toolbar and status
bar off when first selected.  Selecting Full screen again will turn
both elements back on.

One chart, Two charts, Four charts controls how many charts are
being displayed.  Each chart is independent of the others, with its
own tree listing data and set of mapped items.  A user may thus
plot animal populations on one chart, and animal conditions on a
second, for example.  Note that the current setting for the number
of charts shown may change without using this menu.  If a user
attempts to add data to a chart that already has data, and the two
data types have different units, the user will receive a warning and
SavView will ask what they wish to do.  The user may then select
“More charts”, which will increase the number of charts displayed,
from one to two, or two to four.

The View menu contains another View
submenu, listing a series of choices
changing the way SavView
displays information.

Toolbar is a toggle switch - select it
once to turn-off the toolbar across
the top of SavView (and remove
the check next to the menu item).
Select it again to have the toolbar
displayed.

Status bar is a toggle switch - select it
once to turn-off the status bar
across the bottom of SavView (and
remove the check next to the menu
item).  Select it again to have the
status bar displayed.
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One map set, Two map sets, Four map sets controls the number of
groups of maps that SavView will display.  As for charts, each map
set is independent from the others, with its own tree of values and
mapped item.  Note that there can be only 12 maps displayed at a
given time.  If One map set is selected, up to 12 months of data
may be displayed.  If Two map sets is selected, two sets with six
months each may be displayed.  If Four map sets is selected, each
map window will contain only one map, to avoid confusion.

Map color key is a toggle switch that will turn-on and turn-off the
color key and detailed information for on the right-hand side of the
map display.

Control results is not yet implemented, but is considered an important
improvement.  When toggled on, charts would have results from a
control model automatically overlaid upon the items selected.  In
mapping, the Two map sets (or Four map sets) options would be
automatically selected, and the second set of maps would contain
control model results, updated automatically to mirror the user’s
requests.
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Menu Items in SavView - Run, Help

The Help menu provides assistance,
information, and ways to contact
Savanna and SavView authors.
ALT-H is a shortcut to enter the help
menu.

Topics opens the help file associated
with SavView, showing the top-level
help topic.  F1 is a shortcut for the
topics

Search opens a window that allows a
user to search the help file for
specific information.  F2 is a
shortcut to search the help file.

The Run menu allows a user to run the Savanna
model.  ALT-R is a shortcut.

Normal writes the values set by the user to the locations Savanna
needs them for its use, then opens a window that allows the user to
start Savanna.  A colored bar will show the progress of the model
as it completes the simulation.  After entering the Run menu, ALT-
N is a shortcut for the Normal run.

Wizard is not yet implemented.  It would present the user with a series
of questions, rather than having them use the Parameters section of
SavView.  The Savanna model would then run using their
responses as input.

Model description opens another program associated with SavView,
which includes a document describing the Savanna model.  Check
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Glossary opens another program associated with SavView that
contains definitions for words and phrases used in Savanna,
SavView, or its supporting literature.  After entering the help menu,
ALT-G is a shortcut to view the glossary.

Optaining support provides contact information and advice on
optaining technical support.  If Savanna or SavView have failed to
work properly, and trained local personnel are unable to assist,
contact those listed in Optaining support.

About Savanna opens a window that gives information about the
Savanna Modeling System and its author.

About SavView opens a window that gives information about
SavView and its author.

the date on the model description, as it may not be current.
Regardless, the general methods will be correct.
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Buttons on the Toolbar in SavView
Toolbar buttons provide a shortcut to entries that usually appear in

program menus.  SavView has one toolbar, but buttons are added
to it when viewing charts or maps.

Most of the buttons to be shown are also menu entries, which have
already been described.  Buttons without menu entries will be
described in more detail.  The following buttons are always visible
(but may be grayed-out, because they cannot be used at a given
moment):

When working with charts, a button is added to the starting toolbar.
Pressing the blank chart will clear the active chart of all lines
plotted.   This has the same effect as unselecting each of the
currently selected lines, but is faster.

Open - Opens a file.
 Save - Saves a parameter file.

   Save as - Saves a parameter file to a new name.
Revert - Restores changed values to those in the original

file.
       Print - Prints charts or graphs.

     Parameters - View and change parameter values.
   Chart - View and change charts.

Maps - View and change maps.
Run - Run the Savanna model
        Help - Open the SavView help.

If you move the mouse pointer over one of these buttons and pause, a
tooltip is shown, reminding you of the button’s funtion.

Viewing charts

Always shown
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When working with maps, seven new buttons are added.  When first
seen, the display may look like the bar above, with some buttons
depressed or disabled.

The first new button ‘-’ reduced the number of maps shown in the
selected map set. In the figure it is disabled because only one map
was shown.  The second button ‘+’ increases the number of maps
shown.

The last set of buttons control how maps change when advanced.  The
first, depressed button is the default, meaning maps are advanced
manually.  Pressing the second button with the solid black circle
will display monthly maps in succession, looping over years.  The
next button, with the broken circle, will display a constant month,
over years.  The button with a quarter arrow will display all months
of a single year, cycling over that year.  Finally the last button,
disabled above, will make all the map sets advance at the same
time, keeping dates shown the same for all the maps.

Viewing maps
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Displaying trends over time in SavView is straightforward, once a
few ideas are understood.  As mentioned, trees showing how the
things that can be charted are displayed on the left.  On the right
can be one, two, or four separate charts.  Note that each chart has
its own tree of variables.  When SavView is used the first time,
there should be one chart shown.  Expanding that chart’s tree for
“Vegetation”, then expanding “Biomass” and clicking upon
“Leaves” will create a chart like that shown.  Notice that for some
variables, like “Leaves”,
several lines can be
plotted by clicking just
one box.  Individual
lines could be removed
by unchecking their
individual entries.

You may wish to look at
more than one type of
information.  If so, you
might go to the “View”
menu, then select “View” and “Two charts”.  Two charts will be
displayed, with the chart currently selected having a black box
around it.  Each chart has its own tree, so as you click one chart or
the other, the tree will
change (unless the trees
look the same at the
moment).  With this
arrangement, we can now
plot two related pieces of
information, such as
animal populations and
conditions:

Charts in SavView
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The maximum number of charts that can be shown is four.  Again,
each chart will have its own tree and can chart a unique set of
variables.  Here,
for example,
biomass
information for
general plant
groups, livestock
populations and
conditions, and
rainfall are plotted.

Exercise:  Using
SavView, open the
control model for NCA-Savanna, using the methods described on
page 17.  Practice charting variables that interest you.  Use one, two,
and four charts.  Which variables have no information (are zero or do
not make a line)?  Why?
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Charts in SavView (Continued)

SavView is aware of the units of each variable, and will not allow
data with different units to be placed upon the same axis of the
chart.  If you attempt
this, a window like
that on the right
shows, asking for your
input.

If you select “Replace
chart”, the data in the
current chart is replaced with the data you have just selected.

If you select “Overlay line”, SavView will place the new data as a
thin red line over the top of the existing lines, using the axis on the
right for a label.  I will often use the ability of SavView to overlay
a line to plot
precipitation over the
responses I am
examining.  Only one
line can be overlaid
on a chart; if you ask
to show data with a
third type of units, the
“Overlay line” button
will be grayed-out.
Each of the four
charts that can be
shown at one time may have a different variable overlaid upon it,
as shown in the figure on the right.  Of course, using four charts,
especially with overlaid information, can be overly confusing.
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Finally, if you select “Cancel”, the window disappears and the request
for the new information to be plotted is ignored.

If you select
“More charts”,
as you might
guess, more
charts are
added to the
SavView
window, and
the data you
had just asked
to be plotted is
placed in the
new chart.  If there are already four charts displayed, the “More
charts” button is grayed-out, and disabled.
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Maps in SavView are handled similarly to charts, with four sets of
maps that can each have a different thing being mapped.  Unlike
charts, each set of maps can have only one type of information
mapped.  You’ll notice the difference when you click on an entry in
the tree of variables.  Any other checked variables will be
unchecked, as the new variable is mapped.

There can be one, two, or four
sets of maps, adjusted in the
same menu as charts (“View”,
“View” and a given number of
map sets).  For example, when
SavView first is used, a single
map set is shown, as on the
right.  Setting the number of
map sets to two would yield a
display like that shown in the
lower right.

An important difference in SavView
is between map sets and individual
maps.  As mentioned, SavView
can display up to four map sets -
four different types of
information.

But, up to 12 individual maps may be
displayed, depending upon the
settings.  When one map set is
shown, 1, 2, 4, 6, or 12 maps may

Maps in SavView



129

be displayed.  Each shows
output from a particular
month.  That is, if six maps
were shown, and the first
showed January, the second
would show February, the
third March, and so on.  With
12 maps selected, a full year
of output is displayed.
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Whereas a full year may be
displayed when a single map set
is selected, when two map sets
are selected, each can show up to
six months (1, 2, 4, or 6 maps).

When four map sets are being
shown, the screen would be too
crowded to show many months
for each map set. When four map
sets are shown, only one map is
shown for each.

At the bottom of most of the map sets you’ll notice the following bar:

The bar controls the time period mapped.  The year is shown in the
left window, followed by a scroll bar used to set the year.  The
month is shown in the next window, followed by buttons that set
the month to be displayed.  Lastly, two buttons allow the map
shown to be advanced one month at a time, or moved back one
month at a time.

SavView knows the size of its windows, and will change the display
if things fit poorly (in some cases).
If the bar just discussed will not fit
well, it is replaced by a small bar.
Here the year and month are set using buttons.

Maps in SavView (Continued)
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Each map is accompanied by a color bar, showing the
values of colors.  Windows show a series of values,
including the mean value of the data and a range used to
color the map.  The lower limit (“Low”) is the mean
minus twice the standard deviation.  The
upper limit (“High”) is the mean plus twice
the standard deviation.  Intermediate values
are shown as well.  Finally, at the bottom
are the maximum and minimum values in
the data.

Like for the bar controlling the
time period mapped, the color
bar will shrink if there is not
enough room in the window.
First, the intermediate values
disappear, then the color bar
and maximum and minimum
values disappear.


